Jump to content


Photo

Stuttering with Normal FPS, Caused By UI


  • Please log in to reply
19 replies to this topic

#1 Credey

Credey
  • Members

Posted 11 June 2014 - 09:43 AM

I usually get anywhere from 20 FPS in Grimvault to 60 FPS in Housing, and I don't mind. But recently, every second on the dot, the game freezes for a split second. Like, it's not a major freeze, and it's still playable, but it really bothers me. I checked my FPS, it doesn't drop or anything, so it's not an FPS issue. I've noticed that it happens whenever a selectable, non-player entity is on the screen.

 

But here's the kicker: If I do ALT + Z and turn off the UI, the stutter stops. Entirely. I've tried deactivating all my installed player-made addons, and the issue remains. I was wondering if anyone knows what causes this, so I can turn it off or replace it. I know for sure that it's not Nameplates, or Bijiplates.



#2 TerkerKnight

TerkerKnight
  • Members

Posted 11 June 2014 - 10:32 AM

Having the exact same issue. Every second on the dot I Iose frames. Makes pvp unplayable. I havnt tried th alt+z yet. I will when I get home. Lots or people seem to have this issue. I hope it is addressed soon.

#3 TerkerKnight

TerkerKnight
  • Members

Posted 11 June 2014 - 02:21 PM

Having the exact same issue. Every second on the dot I Iose frames. Makes pvp unplayable. I havnt tried th alt+z yet. I will when I get home. Lots or people seem to have this issue. I hope it is addressed soon.

Confirmed turning off the UI with Alt-Z stopped the studdering. Now to determine exactly whats causing the issue. Still no response from Carbine regarding this. 



#4 Evaridlee

Evaridlee
  • Guests

Posted 11 June 2014 - 02:26 PM

Are you running on dx9 or 11. I had this problem and switching to dx11 resolved it.

#5 XTrauma

XTrauma
  • Members

Posted 11 June 2014 - 03:25 PM

I was experiencing the same thing. I switched the game back to DX 11 and funnily enough the patch seems to have given me better performance even though I'm on an Intel CPU. 

If you have it in DX9 try going deleting that from your target line and see if it helps any.



#6 Credey

Credey
  • Members

Posted 11 June 2014 - 04:14 PM

Are you running on dx9 or 11. I had this problem and switching to dx11 resolved it.

I've always ran on Dx11.



#7 Ngamok

Ngamok
  • Members

Posted 11 June 2014 - 04:32 PM

I get this exact same thing.  Running the game in DX9.  Using Alt+Z closing the UI makes all the stuttering disappear.



#8 TerkerKnight

TerkerKnight
  • Members

Posted 11 June 2014 - 04:49 PM

I was experiencing the same thing. I switched the game back to DX 11 and funnily enough the patch seems to have given me better performance even though I'm on an Intel CPU.

If you have it in DX9 try going deleting that from your target line and see if it helps any.


I have a Radeon 4800 series. It does not support dx11 so this is not an option for me. It worked fine before the patch. I will be using process of elimination to determine exactly which part of the UI is causing it tonight.

#9 Ngamok

Ngamok
  • Members

Posted 11 June 2014 - 05:10 PM

I turned off the quest tracker and it doesn't stutter :(

 

Edit: I lied it decreases the time between from 2s to 4s



#10 Credey

Credey
  • Members

Posted 11 June 2014 - 06:56 PM

I have a Radeon 4800 series. It does not support dx11 so this is not an option for me. It worked fine before the patch. I will be using process of elimination to determine exactly which part of the UI is causing it tonight.

 

Please report back to us with what you find! I hate this bug so much. It's so small that Carbine might not fix it, but big enough to bother me in crowded zones.



#11 Hunter Wild

Hunter Wild
  • Members

Posted 11 June 2014 - 08:53 PM

So I haven't quite nailed this down.

 

This only began occurring for me after yesterday's patch, build 6723. As far as I can tell the exact same thing is happening to me, but only in instanced zones and never in the open world.

 

What happens: I will stick right around 30 fps without any serious fluctuation but the screen will stutter for just a fraction of a second at completely regular intervals without deviation, as described by the OP, but perhaps not in second-long intervals specifically.

 

I was questing in the open world without any issues when I queued up for Walatiki Temple. Once I got in I experienced nothing but this regular stutter, and it was immediately apparent that it wasn't lag and I could also see that my framerate hadn't dropped. Upon finishing I was dumped back into the open world and had no stutter whatsoever. I restarted my PC and tried another round of Walatiki Temple, which gave me the exact same issue with the exact same timing. I stayed in the open world to quest for the next several hours until I got to The Steady Traveler instance in Deradune where I had the same experience again, only this time without any other players in a relatively small room seemingly without any relevant drains on my system.

 

I, too, thought that it could be addons so I reset the addons to Default which removed all the player mades. Instead of going away, the stutter interval changed; it was just longer between each stutter by about 1.5-2x what it was before. Reloading all the player made addons seemed to bring it back to the original stutter timing.

 

Finally I found this post and tried Alt+Z. I was surprised again to find that the stutter almost seems to go away, or rather it turns into something that I would be more inclined to say looks like lag. If there's a pattern to the stutter when the UI is off I can't notice it, but I am still noticing the same tiny frozen frame for a split second here and there in a way that I just don't experience in the open/non-instanced world.

 

 

Windows 7 SP1 x64

Intel i7 3.20 quad

12 GB DDR

2x ATI Radeon HD 4870, xfire

DX11



#12 TerkerKnight

TerkerKnight
  • Members

Posted 11 June 2014 - 10:28 PM

I couldnt really pin point the issue like I thought I was going to be able to. I've been running the game on low with shadows "off." Its not pretty but is just playable enough to where I can wait for them to fix it. 



#13 Kurona

Kurona
  • Members
  • LocationYour Mom's House

Posted 11 June 2014 - 11:55 PM

try disabling combat log addon. it affects performance badly at times.


Kurona Silversky

<Diplomacy> <World Last>


#14 Hunter Wild

Hunter Wild
  • Members

Posted 12 June 2014 - 07:30 AM

You should consider putting your specs in with your posts. It might be helpful to both Carbine and the rest of us in figuring out the source of the problem.

#15 Ngamok

Ngamok
  • Members

Posted 12 June 2014 - 10:15 AM

It's dx9 related.  I was running my Wild Star client with the -dx9 on the launch icon to get a few extra fps on the game client because I am currently running the game on an AMD A10-6700 APU.  Only till I get a new power supply and put in my old nvidia 550 Ti in.  So I took it off and let the game run in dx11 and the issue goes away.  So the UI is having the problem running in the dx9 environment.



#16 Blockypixel

Blockypixel
  • Members

Posted 12 June 2014 - 10:52 AM

I'm having the exact same issue, except I'm pretty sure I'm running the game in Dx-11. I haven't been able to do the UI test you guys are doing because I've been unable to log in at all for 3 days due to a different error.

#17 Hunter Wild

Hunter Wild
  • Members

Posted 12 June 2014 - 11:29 AM

Yeah, I'm also here to say that it's not inherently DX9 related. As I noted in my system spec above, I've been running the game with DX11 the entire time, from open beta to today. I never had this issue until the most recent patch. After reading this thread earlier I went back and re-checked my version and it's still DX11, and I'm still having the problem as of two minutes ago. I wish it were as simple for me as upgrading my DirectX.



#18 Hunter Wild

Hunter Wild
  • Members

Posted 21 June 2014 - 04:31 AM

One of yesterday's hotfixes, Build 6745.0, was supposed to fix stuttering for some people. It turns out I'm not one of those people. I still can't do BGs due to this stutter and I try to spend the least amount of time in any other instanced zones, including my own housing lot.

 

Just to be clear, I don't hate you, Carbine, for not having this fixed yet. It's apparently a really small group that this is happening to, and there are a whole lot of other issues that are affecting a significant portion of the WildStar community. Keep on fixin what yer fixin. I just hope that eventually this will get resolved either on accident when you fix something else (since this only started with one of the hotfixes anyway) or that this can otherwise get resolved for me in the relatively near future anyway.

 

Edit: Something else has started happening, too, and it's been making me think more about it being something on my end that's conflicting with optimization for other, more up to date rigs. I started running WildStar on Ultra Low settings a while ago because that would make the stutter have the least effect, and I was getting frustrated when I would have to switch video settings every time I went into an instanced zone. (Yes, I know that sounds like a straight up framerate issue, but I hope I made it clear how it isn't in earlier posts.) I would naturally have high framerates in Ultra Low until some times this week, but now I'm hovering around 30 fps, and often times between 20-30, all while having Ultra Low settings. My basic specs are listed below. The rig as a whole is about six years old at this point but runs most games at or near the high end of their graphics settings. For the rare super-graphically-intense game I'll have to turn it down to medium and customize some specific settings to get the quality I want. 20-30 fps in the lowest possible graphics settings plus the constant stuttering in zoned instances is completely ridiculous.

 

If someone from Carbine would literally tell me it was my graphics cards or Windows version I'd at least consider making an upgrade. As it stands, I'm just waiting for the magical hotfix that makes it work correctly.

 

Windows 7 SP1 x64

Intel i7 3.20 quad

12 GB DDR

2x ATI Radeon HD 4870, xfire

DX11



#19 Hejhazala

Hejhazala
  • Guests

Posted 21 June 2014 - 09:23 AM

One of yesterday's hotfixes, Build 6745.0, was supposed to fix stuttering for some people. It turns out I'm not one of those people. I still can't do BGs due to this stutter and I try to spend the least amount of time in any other instanced zones, including my own housing lot.

 

Just to be clear, I don't hate you, Carbine, for not having this fixed yet. It's apparently a really small group that this is happening to, and there are a whole lot of other issues that are affecting a significant portion of the WildStar community. Keep on fixin what yer fixin. I just hope that eventually this will get resolved either on accident when you fix something else (since this only started with one of the hotfixes anyway) or that this can otherwise get resolved for me in the relatively near future anyway.

 

Edit: Something else has started happening, too, and it's been making me think more about it being something on my end that's conflicting with optimization for other, more up to date rigs. I started running WildStar on Ultra Low settings a while ago because that would make the stutter have the least effect, and I was getting frustrated when I would have to switch video settings every time I went into an instanced zone. (Yes, I know that sounds like a straight up framerate issue, but I hope I made it clear how it isn't in earlier posts.) I would naturally have high framerates in Ultra Low until some times this week, but now I'm hovering around 30 fps, and often times between 20-30, all while having Ultra Low settings.

 

 

I have just the same problems as you do Hunter Wild, after last patch i went from 30-40 fps to 10-20 without making any changes in the settings. There was also a thread about this earlier:

https://forums.wilds...-patch/?hl=drop



#20 prolox

prolox
  • Members

Posted 25 June 2014 - 01:05 PM

So i think i just found a major fix, it removed my stuttering and improved my overall FPS.
Im running win7 64bit and for some reason my operating system was not launching the game as dx11 by default.
So i tried the -dx9 launch option ive read alot about but instead of putting in "-dx9" i typed in "-dx11" and now im flying on a smooth cloud of happiness.


< ESPER DPS, #1 Crimson Badlands Ganker on Zhur >